Company Profiles Unavailable
Incident Report for DueDil
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 11:25 UTC
Monitoring
Normal service has been restored, will continue to monitor to ensure that it has been resolved.
Posted Mar 31, 2020 - 11:04 UTC
Update
We are continuing to look into this outage, we hope to have this resolved soon.
Posted Mar 31, 2020 - 10:49 UTC
Update
We are continuing to investigate this issue.
Posted Mar 31, 2020 - 09:49 UTC
Investigating
We are currently investigating this issue.
Posted Mar 31, 2020 - 09:47 UTC
This incident affected: DueDil API (Search, Essentials, Ownership, Financials) and DueDil Web Platform (Web Application - app.duedil.com).