API V4 - Micro outages resulting in reduced availability
Incident Report for DueDil
Resolved
Following a period of monitoring, all API components are operating normally.
This issue has now been resolved.
Posted Apr 15, 2020 - 11:24 UTC
Update
Following our last update confirming successful mitigation, we have downgraded this issue from major to minor impact. Work has continued our work to pinpoint potential bottle-necks and have identified one further area for improvement. A fix will be rolled out in the coming days and we expect to bring this issue to complete resolution. Thank you for your patience while we have performed this analysis.
Posted Apr 07, 2020 - 13:45 UTC
Update
Overnight monitoring complete. Severity of this issue has been greatly reduced and there has been minimal impact on the platform.
Monitoring and root cause analysis will continue today. Thank you for bearing with us, while we attend to this problem.
Posted Mar 26, 2020 - 07:27 UTC
Monitoring
The cause for this issue has been identified as slowdown in response time when calling an upstream provider. Given API throughput, this problem was magnified and led to the brief exhaustion of available resources. We have enforced a more stringent timeout and will continue to monitor overnight.
Posted Mar 25, 2020 - 18:55 UTC
Investigating
We are currently investigating the cause of micro-outages on API V4 resulting in the failure of some calls.
Posted Mar 25, 2020 - 11:04 UTC
This incident affected: DueDil API (Search, Essentials, Ownership, Financials).