Network issues
Incident Report for DueDil
Resolved
Issue has been resolved from our network provider and we do not expect any further impact.
The actual impact to services would have been in a window of about 10 minutes from 11:12 BST
Posted Jul 10, 2019 - 12:23 UTC
Identified
We are currently having network issues and are investigating.
Posted Jul 10, 2019 - 10:22 UTC
This incident affected: DueDil API (Search, Essentials, Ownership, Financials) and DueDil Web Platform (Homepage - www.duedil.com).