www.duedil.com CMS down (Main web application and API remain functional)
Incident Report for DueDil
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 11:05 UTC
Identified
Our CMS provided utilises Fastly who we believe are experiencing technical difficulties.

Duedil core services remain functional.
Posted Jun 08, 2021 - 10:31 UTC
This incident affected: DueDil Web Platform (Homepage - www.duedil.com).