Upstream provider for Peps and Sanctions data temporarily unavailable
Incident Report for DueDil
Resolved
This issue has now been resolved. All services are operating normally.
Posted Mar 18, 2020 - 12:13 UTC
Monitoring
API clients calling our Peps and Sanctions or KYB endpoints will have seen HTTP 503 responses from 7.45am to 9.30am today.
Peps and Sanctions functionality via the Site was also unavailable during this time. Our data provider has resumed normal service and we are now monitoring. Please accept our apologies for this interruption to service.
Posted Mar 18, 2020 - 10:38 UTC
This incident affected: DueDil Web Platform (Web Application - app.duedil.com).