Service Outage
Incident Report for DueDil
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 20:15 UTC
Identified
Our Cloud provider (Google) are experiencing a global network failure. To follow the incident, please refer to https://status.cloud.google.com/incidents/6PM5mNd43NbMqjCZ5REh

We will continue to monitor and update our status accordingly.
Posted Nov 16, 2021 - 18:16 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2021 - 18:09 UTC
Investigating
We are investigating an issue that is affecting our services
Posted Nov 16, 2021 - 18:09 UTC
This incident affected: DueDil API (Search, Essentials, Ownership, Financials, Covid-19) and DueDil Web Platform (Web Application - app.duedil.com).