Service Outage
Incident Report for DueDil
Resolved
Google Cloud incident marked as resolved.
Posted Jul 21, 2022 - 06:47 UTC
Update
Requests appear to have stabilised. We're awaiting an update from Google Cloud: https://status.cloud.google.com/incidents/fmEL9i2fArADKawkZAa2
Posted Jul 19, 2022 - 17:44 UTC
Update
At first we assumed the issue was an internal monitoring solution, but it would appear there may be a wider problem.

Google Cloud have registered an issue within the London region that is likely to be related the issues we're experiencing: https://status.cloud.google.com/incidents/fmEL9i2fArADKawkZAa2
Posted Jul 19, 2022 - 17:20 UTC
Update
It would appear that the request failures are linked to our internal monitoring systems and as such is not an external facing issue
Posted Jul 19, 2022 - 17:08 UTC
Identified
The request failures appear to be an upstream issue. We're contacting our upstream provider for clarification.
Posted Jul 19, 2022 - 16:51 UTC
Investigating
We're currently investigating an issue where a number of API requests return a HTTP 500
Posted Jul 19, 2022 - 16:39 UTC
This incident affected: DueDil API (Search, Essentials, Ownership, Financials, Covid-19).