Timeouts
Incident Report for DueDil
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:10 UTC
Monitoring
We're currently monitoring the Cloudflare incident
Posted Jun 21, 2022 - 07:27 UTC
Identified
The cause has been identified. There is a major outage to one of our upstream providers:

Cloudflare - https://www.cloudflarestatus.com/

We are monitoring the situation closely.
Posted Jun 21, 2022 - 07:21 UTC
Investigating
We are currently investigating an issue where certain requests to our services result in a timeout.
Posted Jun 21, 2022 - 06:59 UTC
This incident affected: DueDil Web Platform (Web Application - app.duedil.com).